THE KNUCK

THE GUNSMITH => THE TECH BOARD => Topic started by: Richo on June 11, 2015, 06:04:36 PM

Title: Windows 10 ... anyone had a play ?
Post by: Richo on June 11, 2015, 06:04:36 PM

I signed up for the freebie upgrade after July29 but has anyone already messed with it ?  Thoughts ?
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 11, 2015, 06:29:15 PM
:)

Yeah mate, been running it on a separate machine for a few days and following along on the tech discussion.

Have to say first impressions pretty damned good, seems to have kept the good, ditched most of the 8 GUI crap (not all, has made it better) and in general actually listened to the uproar whilst still presenting some good new stuff.

I'm just starting to play with Edge, the new browser, again, pretty damned good.

It remains to be seen if it is too little too late, 8 really cost them and can't see corporates rushing to 10 but so far pretty ok OS.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Richo on June 11, 2015, 07:50:45 PM
Cool

I passed up on beta testing or pre release candidate shit on this one. Good to hear your thoughts.
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 12, 2015, 10:57:08 AM
:)

I was going to, until people started saying nice things :)

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Wallacey on June 12, 2015, 11:36:49 AM
I signed up for the free copy too, the only thing I don't like the sound of is the fact that updates are fully automatic in the home version being offered.
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 12, 2015, 11:47:11 AM
:)

Yeah, that really is a weird one.

In practice I've always left updates on anyway but it is nice to have the choice - I guess the thinking is that corporates who are not getting it free really do want that control, home users ought not to know or care :)

Cheers

Title: Re: Windows 10 ... anyone had a play ?
Post by: Richo on June 12, 2015, 07:47:25 PM
Someone will put out a "patch"  :-*
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 13, 2015, 11:58:21 AM
:)

If they haven't already.

Updates on 8.1 just gave me a scare, bombed out in the reboot and tried to tell me I had a SMART error and the HDD was failing, interesting, SMART is not enabled...

Check after getting the system back and no problems found, have a quick Google, known issue, thanks MS...

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Richo on June 14, 2015, 08:08:38 PM

XP had 2 million lines of code.. wonder how many 10 has ?
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 14, 2015, 08:16:39 PM

XP had 2 million lines of code.. wonder how many 10 has ?

:)

Too many... tight code is not a concept programmers really understand much - used to be the mantra :)

Give you an example, Warren halved the code footprint on the project we took over, just slack code, simple as that.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Richo on June 15, 2015, 12:14:25 AM
Oh I don't doubt it.


All of DW's pages are hand crafted HTML in notepad (or gedit). I've made the same page in dreamweaver as an experiment and the code was three times the lines and complex as hell (no bull).



I call it minimalistic effective code ...... eloquence.
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on June 15, 2015, 08:32:28 AM
:)

The modern programmer is the equivalent of a mass polluter - there's lots of resources so let's use them :)

Dreamweaver is a typical code generator in that respect, nothing beats hand coding with HTML.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: AccessDenied on June 19, 2015, 10:50:32 PM
Adding my 2c.

Windows 10 is good.  On a 'standard pc' it's good.

Where it shines is on new generation hardware.

Directx12 graphics card.  UEFI enabled mobo.  SSD Hard drive.  Get those and you get yourself a tame lightning bolt. 

I got the SSD and Directx12, but not UEFI (About $150 upgrade when the time comes).  Even with those, on just a test the boot time was sub 10 seconds.  Everything 'felt' zippy.  From gaming to browsing.  "Edge" is ok..  It's not fantastic.  Yet.  It feels like using an early Firefox.  You could feel the potential.  Still prefer other browsers.  It doesn't get instantly dismissed however.

I think MS are on a winner with this one.

AD
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 05, 2015, 02:48:17 PM
Hmm,

Just downloaded and installed my free upgrade - pretty much a seamless process but it is on a reasonably new HP i5 Pavilion.

I did have to install SP3 for Office 2007, the last version of Office that I like, to get Outlook running, but that aside it's playing nice so far.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 09, 2015, 02:16:55 PM
yup just built a new pc, I7 4790K gtx 980Ti ssd for win10 .. around a 14 second boot, it is for me, a learning curve though, since i've jumped from 7 with no more then 5 minutes with a tablet with 8.1 on it.

So far the only thing thats pissed me off is no more WMP, and im missing my widgets already. Havnt really tried out Edge, only poked at it a little had it a week now, which time has been spend either working, or playing games :P
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 09, 2015, 03:02:57 PM
:)

I never did much with WMP so don't miss itbut lots of others do.

Edge is still pretty raw but it is better than IE, not that that would be difficult ;)

What widgets are you missing?

I'm like many on the curve as well because I put Classic Shell straight onto 8.1 when I bought the HP so had next to no exposure to 8.x per se at all.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 09, 2015, 04:44:37 PM
well all my performance checkers etc... and a simple small desktop clock i had sitting on the second monitor.. well actualy there was 3.. local, + 2 different ones for game servers... what ive found in the ├Ąpp"store sopfar is bloody pathetic.. though to busy playing games to put much time into it atm :p

i do however very much like the taskbars on BOTH monitors... which is about bloody time...
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 09, 2015, 05:04:08 PM
These may help:

http://8gadgetpack.net/

Don't be fooled by the name they run in 10, I'm using the clock, the PC monitor for CPU, RAM and cores and a local weather feed, basically same ones I've had since 7.

The multi-screen stuff started in 8 but it really is good now, don't even have to click to shift screen focus, it just works where the cursor is.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 09, 2015, 05:28:26 PM
Sweet, thanks Hm happy now i have a clock again... its the simple things, wil look at the rest of em later :)
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 09, 2015, 05:33:51 PM
:)

No prob.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 21, 2015, 05:39:26 PM
Just struck first problem with a 10 upgrade, tiny little network of four computers that the client decided to upgrade in one hit.

Two are fine, two not, looks as if they were in a Homegroup and that is borked. I mean really borked, go to one machine and see how it is sharing it insists on joining the homegroup and nominates where the password is, go to that machine and it wants to join the group but denies it owns it :)

Being Middy was on the job and did the configs in the main I'm really not quite sure what I'm looking at so we are going to go sort it tomorrow, there was a third person on the job and we think he actually created the Homegroup - never seen the point in a small work network, a Workgroup is fine for peer-to-peer but apparently from a bit of Googling this has bitten a number of people doing upgrades.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 22, 2015, 06:07:32 PM
Had a problem with the one i upgraded.. just went change homegorup and stuck in the PW for the new pc's grp and done
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 23, 2015, 10:22:44 AM
:)

Yeah this pair don't want to play happy that way but fixed it a different way, ignored the Homegroup and moved the necessary share to the cloud :)

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 23, 2015, 06:43:58 PM
the other issue i have which is just annoying is that even on the second pc, which has no log in or password, when i access its shared from my settop box, i now have to put in the user name, which i never had to do under 7 ...

Oh and im not sure why, but WMP, that was apperantly removed from win10... well not sure if it was a recent update or not, but its there, spotted it via the right click menu on a video
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 23, 2015, 07:16:29 PM
Have no idea on that - 10 is beyond paranoid, which is annoying.

But, does WMP run ? Have had a couple of older apps that appeared but nope... :)

I don't think that really matter,s better options than WMP :)

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 23, 2015, 07:50:53 PM
wmp runs just fine, only had to install the x264 codex for the newer shit, yes theres other options, like vlc...i havnt used vlc for a long long time.. because, frankly compared to wmp at the time, it was fucking shit.. washed out video and muddy sound ..infact the ONLY thing it did better then wmp at the tiome, was play subtitles.

Only prob ive had with wmp is its stuttered on 2 videos, picture wise, so far... but given that i only have the one codex pack for it, and the weird shit some people do with them (both being x264 ) im not overly bothered,mostly i watch movie's via the settop and tv.
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 24, 2015, 09:54:45 AM
Interesting, the Win 10 forums have been making a big deal over WMP not being there.

I don't do video on the PC much at all but what little I do VLC has been fine.

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on August 24, 2015, 05:48:52 PM
yeah i was annoyed i was going to have to get vlc, but the few shows i'd watched on it i'd just used the tv/video app it has ... then suddenly wmp
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on August 24, 2015, 06:21:12 PM
:)

I just don't watch much on the PC, in fact I do not watch much..period, although that might change, Netflix is... interesting :)

Cheers

Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on December 12, 2015, 06:47:55 PM
Hmm,

Here's an interesting one with Win10.

Wife decided that she needed a tablet, possible hospital visits and in her usual fashion bought two, one for me.

After a look around and really thinking the need was hardly onerous found Dick Smith selling Asus T100 TAF for $299 which being a transformer with docking keyboard was a steal - ok Atom, only 2GB RAM, but, tablets, 32GB storage and a nice long tested battery life but Win 8.1. A Win10 upgrade was a given in fact was first pop up on booting but the compatibility wizard did not pick up that more space would be needed for the install.

No biggee, I thought, plugged in a 16GB USB stick and on the install went, until at one reboot it went into repair mode in a loop - could not find the stick...

Being I had two of them and they were bloody slow charging AND discharged under load I assume on first charge only, I left the first one and after a bit of a Google did the second with an external USB spinning disk whilst the first re-charged.

No problem, Win10 all nicely installed just need to piss off all the ASUS crapware and get everything customised but I think I'm going to charge cycle the successful one a couple of times before worrying too much on the finesse.

So as soon as the first one is charged should have no issues getting it finished, Win10 it seems just did not like the stick drivers in one boot for some reason whereas the mech. disk was fine. Could be simpler than that, the USB stick was a good SANDisk but USB2, the drive is a 1TB Samsung and USB3, the USB specification is getting much better at quick recognition :)

What does bemuse me is that after all these years MS programmers STILL have no concept of tidy compact code. Once installed there was almost half of the 32GB free BEFORE I clean up, so the install not only needed that but another 10GB of scratch space as well....

Fucking ridiculous, would love the drug franchise at Redmond :)

Cheers
Title: Re: Windows 10 ... anyone had a play ?
Post by: Richo on December 29, 2015, 01:06:05 PM
Yeah.. bloody M$.

I had an issue with my dual boot lappy after win10 upgrade. That fast start shit that auto engaged on windows fucked up my linux install by not allowing ti to mount my other always connected drives anymore (windows C and data D).

Fix was easy enough by booting into windows and manually disabling their bullshit but still .... those wackers at redmond are not playing nice ....
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on December 29, 2015, 01:50:36 PM
Yeah,

Heard of that happening to someone else just before Christmas - that fast-boot stuff is no way all it is cracked up to be.

Cheers


Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on December 29, 2015, 09:19:20 PM
i dunno, 12 seconds from pressing power button till my ssd installed windows is full up and ready ...seems fast to me :p
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on December 30, 2015, 09:10:01 AM
:)

It is fast Dready, perhaps too fast but it achieves it through various tricks, one of which is what causes the glitch Richo experienced, it does not allow time for some devices to mount properly.

It completely borked an install on a Tablet that I was doing through that little problem.

Overall though it is a pretty good OS.

Cheers

Title: Re: Windows 10 ... anyone had a play ?
Post by: LordDread on December 30, 2015, 11:29:47 AM
yeah im very happy (fuck me with a MS product :/) with win10, had the same thoughts as when i tried xp . win7 ... yeah i will be back to the old OS in a day ... happy to be wrong again. Im on the right upgrade pathing :P workgroups 3.11 & dosshell 7 > 95 > 2k > xp > 7 > 10 :P .. skipped all that rubbish in between. Im still avoiding *nix , cause im sure we still have our old disagreement, nix hates me, so i hate it  rofl  never had any luck getting any nix to install, bad things happen, hardware breaks (coincidence maybe, but i aint taken any chances with decent pc gear :p ),shit just doesnt work..only way i've ever got nix to work is via a boot cd .. which is hardly worth it. Dont get me wrong, theres times when i wish it was different... i'd love a simple effective gateway box,but sadly we just dont get along  ;)
Title: Re: Windows 10 ... anyone had a play ?
Post by: Hardman on December 30, 2015, 02:35:00 PM
:)

*Nix has its place more a case of what distro really, for simple stuff Mint seems the go.

I'm not totally happy with 10 - yet, mainly for some of the useful stuff it has discarded or buried deep but it's stable, fast and not TOO big a hog. I guess we will be debating over builds from hereon :)

Cheers